Wednesday, 26 April 2017

Paintshop Pro error "There was a problem sending the command to the program"

I have had an ongoing problem on my laptop with opening images using PaintShop Pro (PSP) 9, on Windows 8.1. I would click on an image file and, as my default programme is PSP 9, the software opens but without the image I clicked on, and I get a popup saying "There was a problem sending the command to the program".
    The problem is, apparently, that PSP 9 uses an old Windows system called DDE to pass the image to PSP. While DDE is still a Windows component, it no longer works as it should because of tighter Windows security settings.

    The solution that I found was from MyComputerGirl (30 March 2011), who advises that to repair, we should:
      1. Open Regedit
      2. Go to the following string: HKEY_CLASSES_ROOT\Applications\Paint Shop Pro 9.exe\shell\open\command
      3. Change the "Default" entry to "C:\Program Files (x86)\Jasc Software Inc\Paint Shop Pro 9\Paint Shop Pro 9.exe" "%1"
      4. Delete the following string (which is immediately below the string you just edited): HKEY_CLASSES_ROOT\Applications\Paint Shop Pro 9.exe\shell\open\ddexec
      5. Exit Regedit
      6. Open a picture file as you typically would from windows explorer and it should open without error.
        And she was SO right. It works perfectly. It also works in Windows 7, for those of you still using that version of Windows.


        Sam

        No comments :

        Post a Comment

        Thanks for your feedback. The elves will post it shortly.